Almost-functioning SDR V2 to a good home (60M-20M)

General discussion and support for the Peaberry SDR V2.

Almost-functioning SDR V2 to a good home (60M-20M)

Postby k1qn » Wed Jul 08, 2015 6:41 pm

Please see my current topics on this forum.

Background:

It ran fine for hours/days on end, then the RF output power dropped slowly. This was traced to slowly falling audio output on the 4 lines (VOUTL+, VOUTL-, VOUTR+, VOUTR-). No one had ever seen anything like it. I figured I traumatized the PCM3060 and replaced it.

Now, the PC finds the Si570 and the PCM3060, but the PCM3060 simply doesn't function as a D-A or as an A-D. No audio on receive or transmit.

I checked continuity on every single pin on the chip.

Software tests include running my other Peaberry SDR V2 from the exact same USB port and cable.

Make me an offer. In lieu of direct payment, I may consider charitable contributions.

(This is not a hack soldering job. It's my 4th SDR project - 2 softrocks, plus another Peaberry.)
Al Gerheim, K1QN
Celebrating 50 years in ham radio!
k1qn
 
Posts: 90
Joined: Sun Oct 20, 2013 9:42 pm

Re: Almost-functioning SDR V2 to a good home (60M-20M)

Postby k1qn » Wed Jul 08, 2015 7:11 pm

That was fast.

I got a private reply, and it'll be in the mail in response to a generous gift to the Wounded Warrior Project.

I want to build another, and I wish the proud owner the best luck!
Al Gerheim, K1QN
Celebrating 50 years in ham radio!
k1qn
 
Posts: 90
Joined: Sun Oct 20, 2013 9:42 pm

Re: Almost-functioning SDR V2 to a good home (60M-20M)

Postby k1qn » Wed Jul 08, 2015 7:27 pm

I'll try to get it wrapped today (busy with a family visit).

BTW, after you debug it, please let me know what was wrong. It really killed me!

I saw your QRZ page. Love the mods for your 2 PB's. :-)
Al Gerheim, K1QN
Celebrating 50 years in ham radio!
k1qn
 
Posts: 90
Joined: Sun Oct 20, 2013 9:42 pm

Re: Almost-functioning SDR V2 to a good home (60M-20M)

Postby W4MMP » Tue Jul 14, 2015 2:27 am

Hi Al,

You're gonna love this :shock: About 15 minutes on the bench and it is working. A little bit of flux, desoldering braid and some heat and it is working. I believe either VINR or VINL were not making contact. When I first attached to the rig to the computer, HDSDR was displaying the "buzz saw" that has been mentioned several times on this board. That is an indication that one side of the balanced audio is not working proplery. It can happen anywhere in the receive audio chain. But since the PCM3060 has been replaced it was a safe bet the issue was with the PCM3060 solder connections. Also, power output is good and stable. The rig was key down for 10 minutes in FM mode (to a dummy load) and it maintained a consistent power output.

Now onto changing the coils and transformers for 160/80M and my station will be complete.

Thanks and I know the Wounded Warrior Project will put the donation to good use.
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: Almost-functioning SDR V2 to a good home (60M-20M)

Postby k1qn » Tue Jul 14, 2015 8:40 pm

Somewhat mixed feelings. I'm happy my only critical mistake was giving up too soon, and I'm happy I could help the Wounded Warrior Project.

To be totally honest, it was lots of fun to build. My biggest disappointment is that the kit is sold out, and I can't crank another one up right away!
Al Gerheim, K1QN
Celebrating 50 years in ham radio!
k1qn
 
Posts: 90
Joined: Sun Oct 20, 2013 9:42 pm


Return to Peaberry SDR V2

Who is online

Users browsing this forum: No registered users and 4 guests

cron