Storm fried a resistor

General discussion and support for the Peaberry SDR V1.

Storm fried a resistor

Postby hansvi » Sat May 11, 2013 6:35 pm

Hello,

A few days ago there was a storm nearby, and apparently it was close enough to get some static electricity buildup on the antenna. Suddenly a puff of smoke came out of my peaberry. I immediately unplugged the power but the damage was done: R43 is completely burnt. At the time the peaberry was not doing anything, it was just attached to the computer.
Visually it's the only component that failed, but looking at the schematic, maybe Q8 could have been damaged too. I've been looking for replacement resistors, but I could only find 2.7 Ohms, or I could make a tower of 2x 4.7 Ohms, giving me 2.35 Ohms. Is that close enough or should I keep looking? If so, should I only replace R43 or do I need to keep R43 and R42 at the same value?

Thanks In advance,
Hans.
73,
Hans - ON8VQ
hansvi
 
Posts: 70
Joined: Wed Apr 24, 2013 3:37 am

Re: Storm fried a resistor

Postby AE9RB » Sat May 11, 2013 7:40 pm

You should replace R42, R43, Q6, Q7, and Q8 at least. Use 2.2 or 2.21 ohm 1% resistors. If you change the transmitter design then you will need to run IMD and spurious emissions tests.
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Storm fried a resistor

Postby hansvi » Sat May 11, 2013 9:50 pm

Ok. I desoldered all those components. I highly suspect that the problem only lies with Q8/R43.
Anyway, while I'm at it, it's no big effort to replace the extra components, and that way there is less chance of hidden, lurking problems.

Just FYI, R43 measures 15 Ohms, Q8 measures 8 Ohms between source and drain. R42 measures 2.2 Ohm, Q7 = Q6 = 5.8 Mega-ohm.

Rebuild will have to wait until I find a good replacement resistor.
73,
Hans - ON8VQ
hansvi
 
Posts: 70
Joined: Wed Apr 24, 2013 3:37 am

Re: Storm fried a resistor

Postby hansvi » Thu May 16, 2013 11:30 pm

I rebuilt the transceiver, and everything is working again. In the future, I'll be more cautious about stormy weather :-).

Thanks for the help.
73,
Hans - ON8VQ
hansvi
 
Posts: 70
Joined: Wed Apr 24, 2013 3:37 am

Re: Storm fried a resistor

Postby hansvi » Sat May 25, 2013 1:08 am

It seems there may still be a lingering problem. I post it here because it might be related to the storm event, although it's not sure. I did an experiment with DRM (a digital SSTV mode), and transmitted an image (while I followed the transmission from the Twente WebSDR). Since then, the receiver has been very quiet, I could only hear a few very strong stations on 40m. Noise is lower too.

I talked about it at the local HAM club, and the consensus was to remove Q1 and Q2, and place a permanent wire bridge where Q1 was. As long as I don't transmit, everything should be fine.

Back home, I implemented the change and my reception is back to normal. I'd say it's even better than before. I included a picture of 40m reception, taken just a moment ago. I like it a lot.

One thing I noticed is that the voltage at the gate of Q1 was 1.62 Volt. I had already measured that pin before (after the storm, but before the RX went dead), and back then it was also 1.62 Volt. I should have looked deeper into this at the time, but I didn't (I thought it was strange, but it seemed to be working). Now that Q1 is removed, the voltage at that pin is 5V, which makes more sense.

There was definitely something wrong with the FET's. I don't know if it has been a problem from the start, or what caused the degradation after transmitting. I'll replace them soon.
Attachments
quisk-40m.jpg
quisk-40m.jpg (216.9 KiB) Viewed 10296 times
73,
Hans - ON8VQ
hansvi
 
Posts: 70
Joined: Wed Apr 24, 2013 3:37 am

Re: Storm fried a resistor

Postby AE9RB » Sun May 26, 2013 1:06 am

Indeed, Q1 is expected to fail if your antenna gets some lightning.
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)


Return to Peaberry SDR V1

Who is online

Users browsing this forum: No registered users and 1 guest

cron