[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
AE9RB • View topic - ExpertSDR

ExpertSDR

General discussion and support for the Peaberry SDR V2.

Re: ExpertSDR

Postby W4MMP » Tue Apr 21, 2015 4:14 pm

73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: ExpertSDR

Postby kk4tye » Tue Apr 21, 2015 4:43 pm

Ok,
Thanks for the info, now I gotta get Jackd
73
Mike/KK4TYE
kk4tye
 
Posts: 24
Joined: Tue Jan 27, 2015 4:35 am
Location: Mechanicsville, VA

Re: ExpertSDR

Postby florin.tanasa » Tue Apr 21, 2015 9:05 pm

Hi Ron,
I add splash screen, default font Times New Roman for can see more good what is write in Options, translation posibility for russian guy because
they have linquist file and also check if hardware suport OpenGL 1.2, so if you have trouble in arm hardware comment the lines from main.cpp where check for opengl.
Also bad news I installed Voyager linux last version and Manjaro KDE also last and I have trouble with expertsdr - crash after approx. 20s with libs compilled qt4 or qt5
from system but work with qt5 from qt site.
Until now only me have this problems.

KK4TYE in theory work with plugins ExtIO_ so if you check on the net you found some examples for more SDRs and looking in plugins (openexpertsdr) directory you found files to work with your plugins.

another tip is the plugins to be in system path /usr/lib or /usr/local/lib and only symbolic link to be in device directory
Is not necessary to be programmer because also I am not programmer but I try to learn fast :)
florin.tanasa
 
Posts: 33
Joined: Thu Apr 02, 2015 8:03 pm

Re: ExpertSDR

Postby W4MMP » Wed Apr 22, 2015 12:21 am

73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: ExpertSDR

Postby florin.tanasa » Wed Apr 22, 2015 4:57 am

Ron nest time when I compile at odroid u2 I put binary in repo and test in your raspi.
I tell you when is done.
florin.tanasa
 
Posts: 33
Joined: Thu Apr 02, 2015 8:03 pm

Re: ExpertSDR

Postby W4MMP » Wed Apr 22, 2015 2:48 pm

Hi Tanasa,
Thanks.


I'm giving up on this effort to port OpenExpertSDR to the RPi 2 running Raspbian. I simply do not have the background technical knowledge to make this work. The latest issue is with the Raspbian (Linux) sound subsystem. I like Linux but the sound subsystem is the worst implementation of a subsystem I have ever seen. It truly is an example of "not invented here".

So, I think I focus on having some fun operating CW and such.
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: ExpertSDR

Postby florin.tanasa » Fri Apr 24, 2015 6:36 pm

Hi Ron,
I added a new repo for binary
https://github.com/florintanasa/binary
Try with you device and is necessary some libs from qt post.
This binary was compiled to read libdttsp.so from current directory so move directory ExpertSDR to your home user ~/
florin.tanasa
 
Posts: 33
Joined: Thu Apr 02, 2015 8:03 pm

Re: ExpertSDR

Postby W4MMP » Sat Apr 25, 2015 2:45 am

Hi Tanasa,

Please, be more specific about where the libdttsp.so must be located. I have installed the binary in my home directory along with the library. However I receive a pop up window with the message: Can't load DttSP lib! .

Please provide to me the specifics of where you have ExpertSDR installed and where the library is installed. My home directory is : /home/ron.

Thanks,
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: ExpertSDR

Postby florin.tanasa » Sat Apr 25, 2015 3:58 am

Hi Ron,
I have all files binary in the same directory.
At you is necessary to be in:
/home/ron/ExpertSDR
and in this directory is necessary to have : ExpertSDR binary and libDttSP.so (put all files libDttSP.so.0 , libDttSP.so.0.0.0, etc)
at mine is /home/odroid/ExpertSDR with all files.

73,YO8TFF, Florin Tanasa
florin.tanasa
 
Posts: 33
Joined: Thu Apr 02, 2015 8:03 pm

Re: ExpertSDR

Postby florin.tanasa » Sat Apr 25, 2015 4:51 am

Look Ron
odroid@odroid:~/ExpertSDR$ ls -l
total 6068
-rw-rw-r-- 1 odroid odroid 6535 apr 25 07:39 command_memory.txt
-rwxrwxr-x 1 odroid odroid 5933655 apr 24 21:52 ExpertSDR
-rw-rw-r-- 1 odroid odroid 0 apr 10 18:50 ExpertSDR_QuickWave.wav
lrwxrwxrwx 1 odroid odroid 17 apr 24 20:12 libDttSP.so -> libDttSP.so.0.0.0
lrwxrwxrwx 1 odroid odroid 17 apr 24 20:12 libDttSP.so.0 -> libDttSP.so.0.0.0
-rwxr-xr-x 1 odroid odroid 129676 apr 7 17:31 libDttSP.so.0.0.0
-rw------- 1 odroid odroid 131354 apr 25 07:39 Options.ini
-rw------- 1 odroid odroid 1234 apr 25 07:39 SunSDR.ini

The libs *.a and *.la (for libtool) is statically libs for libDttSP is not necessary but we put for someone wish to make new software where the lib is added statically.
Now I check and work. If i move the libs I have normal the same message like you if I put back ExpertSDR is run and up.
Also for libDttSP is necessary to have libfftw3f installed, libm and libpthread look:

odroid@odroid:~/ExpertSDR$ ldd libDttSP.so
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6f60000)
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6ef3000)
libfftw3f.so.3 => /usr/lib/arm-linux-gnueabihf/libfftw3f.so.3 (0xb6d9b000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6cb4000)
/lib/ld-linux-armhf.so.3 (0xb6fd7000)

I think you put only the libDttSP.so and this only a symlink.
73, YO8TFF, Florin
florin.tanasa
 
Posts: 33
Joined: Thu Apr 02, 2015 8:03 pm

PreviousNext

Return to Peaberry SDR V2

Who is online

Users browsing this forum: No registered users and 4 guests

cron