Unable to compile with MSVC 2010

Unable to compile with MSVC 2010

Postby ks1h » Sun Mar 22, 2015 1:56 pm

David, when I try to build peaberrycw with "Qt Creator 3.3.2 (opensource) Based on Qt 5.4.1 (MSVC 2010, 32 bit)", I get ~350 syntactical errors. I'm guessing it is designed to built with some specific compiler directives, or maybe a different version of QT. Any advice on getting it to build properly?

73, Ken KS1H
ks1h
 
Posts: 47
Joined: Sun Dec 22, 2013 6:50 pm

Re: MSVC 2010

Postby W4MMP » Sun Mar 22, 2015 2:40 pm

Hi,
Thanks for posting this. I hope David responds. I am experiencing the same issue. I'm pretty sure it some type of configuration parameter but I'm really new with Qt.
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: Unable to compile with MSVC 2010

Postby ks1h » Thu Mar 26, 2015 6:37 pm

OK, I got it to build and run OK with qt-opensource-windows-x86-mingw491_opengl-5.4.1.exe

73 Ken KS1H
ks1h
 
Posts: 47
Joined: Sun Dec 22, 2013 6:50 pm

Re: Unable to compile with MSVC 2010

Postby ks1h » Thu Mar 26, 2015 9:03 pm

Maybe I should have been clearer ... go to url:
https://www.qt.io/download-open-source/#section-2
and pick the 7th item under "Windows Host".


Ken KS1H
ks1h
 
Posts: 47
Joined: Sun Dec 22, 2013 6:50 pm

Re: Unable to compile with MSVC 2010

Postby W4MMP » Thu Mar 26, 2015 10:10 pm

Hi Ken,
Thanks for the link. I will give a go also. I have yet to successfully compile any Qt based applications on either Windows or Linux. It appears the open source version of QT has some serious release compatibility issues.
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: Unable to compile with MSVC 2010

Postby W4MMP » Fri Mar 27, 2015 12:20 am

Hi Ken,

Using the link you provided I was able to successfully compile the source. However it fails to run with:
Screenshot 2015-03-26 20.00.58_cr.png
Screenshot 2015-03-26 20.00.58_cr.png (231.26 KiB) Viewed 9359 times



Does your compiled version run properly?
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG

Re: Unable to compile with MSVC 2010

Postby ks1h » Fri Mar 27, 2015 9:57 am

Hi Ron,

It runs OK using the run command in the QT build menu. To run outside of that you will probably need to set a PATH variable to point to the QT library dll's or else copy the right dll's over, but I haven't bothered with that yet.

73 Ken KS1H
ks1h
 
Posts: 47
Joined: Sun Dec 22, 2013 6:50 pm

Re: Unable to compile with MSVC 2010

Postby W4MMP » Fri Mar 27, 2015 12:43 pm

OK Mr. Wizard (aka, Ken)

How did you figure out this was the correct version of Qt to use?

Thanks for all the help !

P.S. I set the path parameter to point to the Qt installation.
73
Ron / W4MMP
W4MMP
 
Posts: 579
Joined: Fri Jan 03, 2014 3:31 pm
Location: Lovettsville, Virginia FM19EG


Return to Peaberry CW

Who is online

Users browsing this forum: No registered users and 1 guest

cron