Invalid Stream Pointer

General discussion and support for the Peaberry SDR V1.

Invalid Stream Pointer

Postby k4fxn » Sun Jan 13, 2013 11:25 pm

I am about 90% done with building my Peaberry. Actually I'm on step 25. I power it up after every few steps to make sure all is OK.

When I configure PowerSDR-IQ Ver 2.4.xx to see what's happening I am getting the following Windows XP error when I try to start the SDR:
Port Audio Error -9988
Invalid Stream Pointer

I am seeing two audio cards; Peaberry Audio and Peaberry Radio. I am using MMX and Peaberry Audio. I also had to change to 6 channels to make another error disappear.

Any ideas? I can post this on the PowerSDR-IQ Group but it seems like the error is related to the sound card.

---------------------------------------
FOLLOW-UP

I changed MIXER to NONE and all seems to be OK.
k4fxn
 
Posts: 5
Joined: Wed Jan 09, 2013 3:40 pm

Re: Invalid Stream Pointer

Postby AE9RB » Mon Jan 14, 2013 9:46 am

Peaberry Radio is the radio interface. No matter what SDR application you use, you must select this interface.
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Invalid Stream Pointer

Postby k4fxn » Fri Jan 18, 2013 2:37 am

I finished construction earlier this week thanks to a lightning quick parts replacement from David.

Everything seems to be working fine with one exception. I am not getting any output from the SPKR jack. Does the new firmware inhibit this jack on 96K, or 48K also? I have checked the on-board hardware and traces and all is fine.

I am using my computer sound card audio output and it is working but am curious about the on-board spkr jack. I have checked it with XP and Vista OS's.

I am using PowerSDR-IQ and have the audio configured as follows
Unsupported Card
Driver MMX
Input Peaberry Radio
Output SoundMAX
Mixer None
Buffer 2048
Sample Rate 48000
Channels 2


Dan K4FXN
k4fxn
 
Posts: 5
Joined: Wed Jan 09, 2013 3:40 pm

Re: Invalid Stream Pointer

Postby AE9RB » Fri Jan 18, 2013 2:50 am

Do you see the Peaberry Audio device? Did you install the 96k jumper?
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Invalid Stream Pointer

Postby k4fxn » Fri Jan 18, 2013 3:00 am

Yes, I see Peaberry Audio and Peaberry Radio drivers.

I did not install the 96K jumper.

Dan K4FXN
k4fxn
 
Posts: 5
Joined: Wed Jan 09, 2013 3:40 pm

Re: Invalid Stream Pointer

Postby AE9RB » Fri Jan 18, 2013 3:25 am

It should work if you see it. There's no trick to it. I don't see how you have the transmitter working if the speaker doesn't work. Did you play music through it when you were instructed during the build?
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Invalid Stream Pointer

Postby k4fxn » Fri Jan 18, 2013 2:09 pm

I can see audio on the Peaberry output using the Windows Control Panel level indicator but just can't hear anything through the SPKR jack. I have checked the circuit board traces and there is continuity (50 ohms) from U11 pins 10 and 11 to the SPKR connector and there are no grounds.

I did not have audio during the build but didn't pay much attention since one of the chips was missing. After looking at the schematic I can see that the audio goes from U11 to the output and the chip was not necessary.

I'll keep troubleshooting and let you know what I find. It's probably a software problem. I just wanted to make sure the audio output was not disabled if the 96K jumper was not used.

Dan K4FXN
k4fxn
 
Posts: 5
Joined: Wed Jan 09, 2013 3:40 pm

Re: Invalid Stream Pointer

Postby edingraham » Sun Jan 27, 2013 12:22 pm

You need amplified speakers, as the instructions say, earphones won't do it.

73, Ed WX4S
edingraham
 
Posts: 11
Joined: Mon Nov 19, 2012 9:37 pm

Re: Invalid Stream Pointer

Postby AE9RB » Sun Jan 27, 2013 11:23 pm

The SPKR jack can only deliver 1/20 watt. Some headphones will work, but not well.
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)


Return to Peaberry SDR V1

Who is online

Users browsing this forum: No registered users and 1 guest

cron