Audio distortion. C1,C2, PCM3060 and Si570 get hot.

General discussion and support for the Peaberry SDR V1.

Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby pu2clr » Sun Nov 25, 2012 4:21 am

I have just rescued my first Peaberry Kit. I had an accident with the PCM3060 and after change it for a new one it is working again.

The Peaberry Audio device is working with distortion (Just the right channel. The left channel is ok). That also was happening before that accident.

The C1 and C2 (electrolytic capacitor 47µF) get warm. D1, Si570 and PCM3060 get very hot.

I can listening station but some times the audio get very fuzzy. If I switch from Peaberry Audio to my Internal output Audio, the receiver works well.
The C1, C2, D1, Si570 and PCM3060 keep hot.

Has anyone any tips to fix this problem?

73,
PU2CLR.
pu2clr
 
Posts: 14
Joined: Sat Nov 24, 2012 2:32 am

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby rw6hch » Sun Nov 25, 2012 12:13 pm

pu2clr wrote:I have just rescued my first Peaberry Kit. I had an accident with the PCM3060 and after change it for a new one it is working again.

The Peaberry Audio device is working with distortion (Just the right channel. The left channel is ok). That also was happening before that accident.

The C1 and C2 (electrolytic capacitor 47µF) get warm. D1, Si570 and PCM3060 get very hot.

I can listening station but some times the audio get very fuzzy. If I switch from Peaberry Audio to my Internal output Audio, the receiver works well.
The C1, C2, D1, Si570 and PCM3060 keep hot.

Has anyone any tips to fix this problem?

73,
PU2CLR.


Check the voltage at the 2 chips U2, according to the scheme of its value should be 3.3 volts, unless otherwise - IC U2 has failed.
rw6hch
 
Posts: 21
Joined: Tue Nov 20, 2012 3:12 pm

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby pu2clr » Sun Nov 25, 2012 2:56 pm

Hi,

The voltage at U2 is 3.31V.
The voltage at U1 is 4,98.

The Power Supply is 12V. Actually it is a Nobreak Battery.
The current draw is about 175 mA

One more thing.
On Windows 7, device configuration, the Microphone Peaberry Audio seems working without a Microphone connected. I mean, the signal level showed on the bar is full green. But there is no Mic installed.

Thanks for the contact.
73.
PU2CLR.
pu2clr
 
Posts: 14
Joined: Sat Nov 24, 2012 2:32 am

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby AE9RB » Sun Nov 25, 2012 5:15 pm

Those parts are expected to be warm. You may have an intermittent short near U7 or U8. How do your transmissions sound? Does the Mic work with a microphone?
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby pu2clr » Mon Nov 26, 2012 1:00 pm

The Mic works but with fuzzy sounds.
The transmitter is not working.

Thanks.
pu2clr
 
Posts: 14
Joined: Sat Nov 24, 2012 2:32 am

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby AE9RB » Mon Nov 26, 2012 5:46 pm

Ok, so three problem? I don't see how they are related. All different parts of the design. Perhaps it's something external to the radio, like the power supply. I suppose it's possible you have made three different mistakes in construction. Three bad parts in one kit would be astronomically rare. Keep debugging and posting the results.
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby pu2clr » Fri Nov 30, 2012 2:23 pm

I Redid the solders at C61, R219, R20 and C26.
The sound output stopped distorting. Now it is good in both channels.
But the Mic behavior continues weird. I mean, without a Mic plugged at the input Jack (J3), it sounds like a Mic plugged. I can see that on Windows 7, Sound configuration.
pu2clr
 
Posts: 14
Joined: Sat Nov 24, 2012 2:32 am

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby AE9RB » Fri Nov 30, 2012 7:32 pm

Great! One down. Keep looking for those simple causes. Illuminated magnification is your friend.
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby pu2clr » Sat Dec 01, 2012 2:19 am

Physically everything seems ok now.
Do you have some advices to debugging the trasminting stage?
Something like voltage test in some points.
By the way, the receiver is very very nice. It is working on my Macbook Pro very well with DSP Radio.
pu2clr
 
Posts: 14
Joined: Sat Nov 24, 2012 2:32 am

Re: Audio distortion. C1,C2, PCM3060 and Si570 get hot.

Postby AE9RB » Sat Dec 01, 2012 2:34 am

Are you sure it's hardware and not software? Does it draw more power when you turn on the transmitter?
73 David AE9RB
AE9RB
Site Admin
 
Posts: 511
Joined: Thu Nov 15, 2012 5:27 am
Location: Portland, Oregon, USA (CN85ql)

Next

Return to Peaberry SDR V1

Who is online

Users browsing this forum: No registered users and 2 guests

cron